Back to overview
Degraded

Elevated API response times (sample)

Jun 19, 2026 at 4:56pm UTC
Affected services
Platform API (api.myorbitcommerce.net)

Resolved
Jun 19, 2026 at 5:32pm UTC

Resolved — the cause was a short-lived database connection spike, now mitigated. All services are operating normally and response times are back to baseline.

Created
Jun 19, 2026 at 4:56pm UTC

We are investigating reports of elevated response times on the Platform API. Customers may notice slower dashboard and storefront loads. Checkout and payments are unaffected.